Trouble accessing certain topics

Don J Davis

Jan 17, 2011
Orange County, CA
When logged in I am able to access the forum categories such as JV, DIY etc but when I try to click on the topic in DIY, 60 degree DIY Mid Hi, it wont allow me to. The clock spins then the page comes up blank.
I have tried on a Mac in Safari and Firefox and on PC in Chrome and get the same results every time.
Other topics don't seem to be a problem.
Tried clearing history, cache made sure everything was enable, javascript etc and same results.

Also using a Mac, same problem- can access the DIY forum and many threads there, but "60 degree DIY Mid Hi" and several others show "error" when clicked from within the forum, and just "spin" when attempt to access directly as the last post in the forum.


Yes, kind of frustrating. Doesn't seem to be platform dependent for me.
Maybe I'll try tapatalk and see if that works.

I've tried it at home, on my iPad out and about and at work. If I log out I can access the thread but can't post. It has to be related to my SF account somehow.